DscCoreR.dll

Associated Error Codes

Below lists error codes and symbolic names found for this module.

CodeFound inDescription
0x500000021011Error
0x500000031011Warning
0x500000041011Information
0x700000011011Send configuration scenario for Local configuration manager
0x900000011011Microsoft-Windows-Desired State Configuration
0xb00010011011Job %1 : This event indicates that failure happens when %2 is processing the configuration. Error Id is %3. Error Detail is %4. Resource Id is %5 and Source Info is %6. Error Message is %7.
0xb00010021011Job %1 : Displaying messages from built-in DSC resources: WMI channel %2 ResourceID: %3 Message : %4
0xb00010031011Job %1 : Method %2 started.
0xb00010041011Job %1 : Displaying messages from the engine: WMI channel %2 ResourceID: %3 Message : %4
0xb00010051011Job %1 : From %2, message is %3
0xb00010061011Job %1 : Operation %2 started by user sid %3 from computer %4.
0xb00010071011Job %1 : This event indicates that a non-terminating error was thrown when %2 was executing %3 on %4 DSC resource. FullyQualifiedErrorId is %5. Error Message is %6.
0xb00010081011Job %1 : This event indicates that failure happens when %2 is trying to get the configuration from pull server using download manager %3. ErrorId is %4. ErrorDetail is %5
0xb00010091011Job %1 : Attempting to get the configuration from pull server using Download Manager %2.Configuration Id is %3.
0xb000100a1011Job %1 : Attempting to get the modules from pull server using Download Manager %2. Configuration Id is %3. Modules are %4.
0xb000100b1011Job %1 : Attempting to get the action from pull server using Download Manager %2. Configuration Id is %3. Checksum is %4. Compliance status is %5.
0xb000100c1011Job %1 : Successfully got the configuration from pull server using Download Manager %2.
0xb000100d1011Job %1 : Successfully got the modules from pull server using Download Manager %2.
0xb000100e1011Job %1 : Successfully got the action %2 from pull server using Download Manager %3.
0xb000100f1011Job %1 : Successfully installed the certificate %2 from %3.
0xb00010101011Job %1 : Skipping installing certificate %2 as it is already installed.
0xb00010111011Job %1 : Successfully deleted certificate file %2.
0xb00010121011Job %1 : Running consistency engine.
0xb00010131011Job %1 : Consistency engine was run successfully.
0xb00010141011Job %1 : This event indicates that failure happened while trying to run consistency engine. ErrorId is %2. ErrorDetail is %3
0xb00010151011Job %1 : Displaying verbose messages from Powershell DSC resource: ResourceID : %2 Message : %3
0xb00010161011Job %1 : Displaying debug messages from Powershell DSC resource: ResourceID : %2 Message : %3
0xb00010171011Job %1 : Method %2 started with parameters Class name: %3 Resource ID: %4 Flags: %5 Execution Mode: %6 DSC resource Namespace: %7
0xb00010181011Job %1 : Method %2 ended successfully
0xb00010191011Job %1 : Current configuration is cancelled. %2 out of %3 resources are not configured.
0xb00010201011Job %1 : Configuration is stopped when Powershell DSC resource is executing.
0xb00010211011Job %1 : Write progress failed with error code %2. The current configuration will be stopped.
0xb00010221011Job %1 : Current configuration is forcely stopped.
0xb00010231011Job %1 : DSC Engine Error : Error Message: %2 Error Code : %3
0xb00010241011Job %1 : Getting a registration instance for %2
0xb00010251011Job %1 : Module manager is loading instance document from location %2
0xb00010261011Job %1 : Validating instance document.
0xb00010271011Job %1 : Deleting instance document from location %2 since it is invalid.
0xb00010281011Job %1 : Parsing the configuration to apply.
0xb00010291011Job %1 : Resolving Dependencies inside the configuration document.
0xb00010301011Job %1 : Setting resources in order. Number of resources: %2
0xb00010311011Job %1 : Processing resource index %2, name %3
0xb00010321011Job %1 : Getting Metaconfiguration details.
0xb00010331011Job %1 : Moving the resource %2 of class %3 to desired state.
0xb00010341011Job %1 : Setting Metaconfiguration instance.
0xb00010351011Job %1 : Saving configuration instance into %2.
0xb00010361011Job %1 : Copying configuration file from %2 to %3.
0xb00010371011Job %1 : Applying configuration from %2.
0xb00010381011Job %1 : Waiting for the current configuration to stop
0xb00010391011Job %1 : Deleting file from %2
0xb00010401011Job %1 : Registering the task with task scheduler after rebooting the machine
0xb00010411011Job %1 : Scheduling a restart of the machine
0xb00010421011Job %1 : Executing operations for PS DSC resource %2 with resource name %3
0xb00010431011Job %1 : Executing operations for WMIv2 DSC resource %2s with resource name %3
0xb00010441011Job %1 : Executing GET for PS DSC resource %2 with resource name %3
0xb00010451011Job %1 : Executing GET for WMIv2 DSC resource %2 with resource name %3
0xb00010461011Job %1 : Invoking session and getting result for namespace %2, classname %3 for method %4
0xb00010471011Job %1 : Getting PS DSC resource schema path and registration information
0xb00010481011Job %1 : Function %2 started with parameters Class name: %3 Method Name: %4 Namespace: %5
0xb00010491011Job %1 : Function %2 started with parameters DataSize: %3 Flags: %4 Execution Mode: %5
0xb00010501011Job %1 : Validating infrastructure schema
0xb00010511011Job %1 : Validating DSC resource registration against schema Number of classes: %2 Number of Registrations: %3
0xb00010521011Job %1 : Validating DSC resource schema against a class array of size %2
0xb00010531011Job %1 : Validating Schema of class %2 which is class index %3 in an array of classes of size %4
0xb00010541011Job %1 : Validating DSC Document instance with instance array size of %2 and flags %3
0xb00010551011Job %1 : Validating DSC resource registration instance for class : %2
0xb00010561011Job %1 : Validating Class property %2 for class %3
0xb00010571011Job %1 : Failed attempt number %2 : Couldn't delete file %3 . The error code is %4. The error message is: %5
0xb00010581011Job %1 : The current metaconfiguration is not registered for Pull configuration mode
0xb00010591011Job %1 : Failed to register the Pull Server Task for the current metaconfiguration
0xb00010601011Job %1 : Failed to register the Consistency Task for the current metaconfiguration
0xb00010611011Job %1 : Failed to copy the configuration from location %2 to location %3
0xb00010621011Job %1 : Failed to delete the current configuration file
0xb00010631011Job %1 : Machine was restarted as needed by one or more DSC resources.
0xb00010641011Job %1 : Restoring the configuration to previous configuration
0xb00010651011Job %1 : Reading the file content from %2
0xb00010661011Job %1 : Consistency Engine did not find a current or pending configuration to apply
0xb00010671011Job %1 : The checksum validation for module %2 completed with status code %3.
0xb00010681011Job %1 : The content validation for module %2 completed with status code %3.
0xb00010691011Job %1 : The modules %2 were downloaded to the location %3.
0xb00010701011Job %1 : The modules %2 were installed at the location %3.
0xb00010711011Job %1 : Attempting to get the modules %2 from pull server with Server Url %3 using Web Download Manager.
0xb00010721011Job %1 : Attempting to get the configuration %2 from pull server with Server Url %3 using Web Download Manager.
0xb00010731011Job %1 : The checksum validation for configuration %2 completed with status code %3.
0xb00010741011Job %1 : The configuration %2 has an invalid format. The configuration name should be a UUID.
0xb00010751011Job %1 : The module %2 has an invalid version format %3.
0xb00010761011Job %1 : Skipping pulling module %2 with version %3 as it already exists in this location %4.
0xb00010771011Job %1 : Extraction for module %2 failed since module path %3 already exists.
0xb00010781011Job %1 : Skipping pulling of modules since all modules specified in configuration %2 are available.
0xb00010791011Job %1 : WebDownloadManager for configuration %2 Get-DscDocument command using certificate id: %3.
0xb00010801011Job %1 : WebDownloadManager processed certificate: %2 %3.
0xb00010811011Job %1 : WebDownloadManager for configuration s Get-DscDocument command, Http Client failed: %2.
0xb00010821011Job %1 : WebDownloadManager for configuration %2 Get-DscDocument command, GET Url: %3.
0xb00010831011Job %1 : WebDownloadManager for configuration %2 Get-DscDocument command, GET call result: %3.
0xb00010841011Job %1 : WebDownloadManager for configuration %2 Get-DscDocument command, Checksum validation failed: %3.
0xb00010851011Job %1 : WebDownloadManager for configuration %2 Get-DscDocument command, File save result: %3.
0xb00010861011Job %1 : WebDownloadManager Get-DscModule command, module %2 using certificate id: %3.
0xb00010871011Job %1 : WebDownloadManager Get-DscModule command, module %2, Http Client failed: %3.
0xb00010881011Job %1 : WebDownloadManager Get-DscModule command, module %2, GET Url: %3.
0xb00010891011Job %1 : WebDownloadManager Get-DscModule command, module %2, GET call result: %3.
0xb00010901011Job %1 : WebDownloadManager Get-DscModule command, module %2, Checksum validation failed: %3.
0xb00010911011Job %1 : WebDownloadManager Get-DscModule command, module %2, File save result: %3.
0xb00010921011Job %1 : WebDownloadManager for configuration %2 Do-DscAction command with server url: %3.
0xb00010931011Job %1 : WebDownloadManager for configuration %2 Do-DscAction command using certificate id: %3.
0xb00010941011Job %1 : WebDownloadManager for configuration %2 Do-DscAction command, Http Client failed: %3.
0xb00010951011Job %1 : WebDownloadManager for configuration %2 Do-DscAction command, GET Url: %3.
0xb00010961011Job %1 : WebDownloadManager for configuration %2 Do-DscAction command, GET call result: %3.
0xb00010971011Job %1 : Module %2 is over written with the downloaded module %3.
0xb00010981011Job %1 : Cannot download configuration from %2. Downloading over HTTP is not allowed.
0xb00010991011Job %1 : From %2, message is %3
0xb000109a1011Job %1 : Message %2 HResult %3 StackTrack %4
0xb000109b1011Job %1 : Operation %2 completed successfully.
0xb000109c1011Job %1 : MIResult: %2 Error Message: %3 Message ID: %4 Error Category: %5 Error Code: %6 Error Type: %7
0xb000109d1011Job %1 : WarningMessage %2
0xb000109e1011Job %1 : DebugMessage %2
0xb000109f1011Job %1 : Activity %2 CurrentOperation %3 StatusDescription %4 PercentComplete %5 SecondsRemaining %6
0xb00010a01011Job %1 : PromptMessage %2
0xb00010a11011Job %1 : Job runs under the following LCM setting. ConfigurationMode: %2 ConfigurationModeFrequencyMins: %3 RefreshMode: %4 RefreshFrequencyMins: %5 RebootNodeIfNeeded: %6 DebugMode: %7
0xb00010a21011Job %1 : Cannot register at %2. Registering over HTTP is not allowed. To ensure security in registration, use an HTTPS address for the ServerUrl in the %3 of the LocalConfigurationManager resource for this device. If you understand the security implications of using HTTP and want to allow its use on this device, set AllowUnsecureConnection property to true in the %4 of the LocalConfigurationManager resource for this device.
0xb00010a41011Job %1 : Http Client %2 failed for WebReportManager for configuration %3.
0xb00010a51011Job %1 : WebReportManager for agent %2 Send-DscStatus command with server url: %3.
0xb00010a61011Job %1 : WebReportManager for agent %2 Send-DscStatus command, POST Url: %3.
0xb00010a71011Job %1 : WebReportManager for agent %2 Send-DscStatus command using certificate id: %3.
0xb00010a81011Job %1 : WebReportManager for agent %2 Send-DscStatus command succeeded.
0xb00010a91011Job %1 : Attempting to send the status report using Report Manager %2. Configuration Id is %3.
0xb00010aa1011Job %1 : Successfully sent the status report using Report Manager %2.
0xb00010ab1011Job %1 : Partial Configuration %2 not available on configuration server.
0xb00010ac1011Job %1 : LCM has resized the resource state cache.
0xb00010ad1011Job %1: Restore default value due to corrupted MOF file %2
0xb00010ae1011The local configuration manager was shut down.
0xb00010af1011The local configuration manager started.
0xb00010b01011One of the input streams to the local configuration manager unexpectedly completed.
0xb00010b11011One of the input streams to the local configuration manager unexpectedly failed.
0xb00010b21011Job %1 : Pulling partial configuration %2 from the server.
0xb00010b31011Job %1 : Starting to apply partial configuration %2.
0xb00010b41011Job %1 : Handling application of configurations in partial configuration mode based on the meta configuration definition.
0xb00010b51011Job %1 : Looking into the partial configuration store to merge any present partial configurations.
0xb00010b61011Job %1 : Merging partial configuration %2 into pending.mof
0xb00010b71011Job %1 : Validating the partial configuration %2 for consistency in configuration Name and exclusive resources
0xb00010b81011Job %1 : Validating the document got from merging all partial configurations
0xb00010b91011Job %1 : Validating the partial configuration definition blocks inside the meta configuration.
0xb00010ba1011Job %1 : Validating that the name of the partial configuration %2 is consistent across the partial configuration .
0xb00010bb1011Job %1 : Validating that the configuration source defined in each partial configuration inside the meta configuration are defined as configuration download managers as well .
0xb00010bc1011Job %1 : Validating that the exclusive resources are not conflicting in the meta configuration definition .
0xb00010bd1011Job %1 : Validating if the exclusive resource %2 is written in the correct format
0xb00010be1011Job %1 : The local configuration manager has applied the configuration successfully.
0xb00010bf1011A crash has occured in Local Configuration Manager.
0xb00010c01011Job %1 : The local configuration manager did not find any current configuration to remove.
0xb00010c11011Job %1 : The local configuration manager failed to remove the current configuration.
0xb00010c21011Job %1 : The local configuration manager was able to successfully remove the current configuration.
0xb00010c31011Job %1 : The local configuration manager is attempting to remove the pending configuration.
0xb00010c41011Job %1 : The local configuration manager did not find any pending configuration to remove.
0xb00010c51011Job %1 : The local configuration manager failed to remove the pending configuration.
0xb00010c61011Job %1 : The local configuration manager was able to successfully remove the pending configuration.
0xb00010c71011Job %1 : The local configuration manager is attempting to remove the previous configuration.
0xb00010c81011Job %1 : The local configuration manager did not find any previous configuration to remove.
0xb00010c91011Job %1 : The local configuration manager failed to remove the previous configuration.
0xb00010ca1011Job %1 : The local configuration manager was able to successfully remove the previous configuration.
0xb00010cb1011Job %1 : Could not wait for the stopping event.
0xb00010cc1011Job %1 : The local configuration manager is attempting to remove the current configuration.
0xb00010cd1011Job %1 : The local configuration manager is attempting to remove partial configurations.
0xb00010ce1011Job %1 : The local configuration manager was able to successfully remove partial configurations.
0xb00010cf1011Job %1 : The local configuration manager failed to remove partial configurations.
0xb00010d01011Job %1 : The local configuration manager did not find any partial configurations to remove.
0xb00010d11011Job %1 : The DownloadManager %2 is invalid. FullyQualifiedErrorId is %3. Error message is: %4
0xb00010d21011Job %1 : The ReportManager %2 is invalid. FullyQualifiedErrorId is %3. Error message is: %4
0xb00010d31011The DscTimer is going to start the consistency timer for the first time with value %1 minutes.
0xb00010d41011The DscTimer is going to start the refresh timer for the first time with value %1 minutes.
0xb00010d51011The DScTimer is updating the consistency timer to the value %1 minutes.
0xb00010d61011The DscTimer is updating the refresh timer to the value %1 minutes.
0xb00010d71011The DscTimer is going to invoke the consistency check for task of type REBOOT.
0xb00010d81011The DscTimer is running LCM method PerformRequiredConfigurationChecks with the flag set to %1.
0xb00010d91011The DscTimer successfully created the consistency timer.
0xb00010da1011The DscTimer successfully created the refresh timer.
0xb00010db1011Job %1 : The local configuration manager is attempting to remove the configuration checksum.
0xb00010dc1011Job %1 : The local configuration manager did not find configuration checksum to remove.
0xb00010dd1011Job %1 : The local configuration manager failed to remove the configuration checksum.
0xb00010de1011Job %1 : The local configuration manager was able to successfully remove the configuration checksum.
0xb00010df1011Job %1 : The local configuration manager is updating the PSModulePath to %2.
0xb00010e01011Job %1 : The local configuration manager could not read the system environment registry for PSModulePath.
0xb00010e11011Job %1 : PsDscRunAsCredential has been specified. The user name is %2.
0xb00010e21011Job %1 : Impersonation successful. Thread is running under the context of %2.
0xb00010e31011Job %1 : Impersonation reverted. Thread is running under the context of %2.
0xb00010e41011Job %1 : WebDownloadManager for AgentId %2 Do-DscAction command with server url: %3.
0xb00010e51011Job %1 : WebDownloadManager for AgentId %2 Do-DscAction command using certificate id: %3.
0xb00010e61011Job %1 : WebDownloadManager for AgentId %2 Do-DscAction command, Http Client failed: %3.
0xb00010e71011Job %1 : WebDownloadManager for AgentId %2 Do-DscAction command, GET Url: %3.
0xb00010e81011Job %1 : WebDownloadManager for AgentId %2 Do-DscAction command, GET call result: %3.
0xb00010e91011Job %1 : Register-DscAgent command for AgentId %2.
0xb00010ec1011Job %1 : Resource execution sequence :: %2.
0xb00010ed1011Job %1 : Attempting to get the configuration from pull server using Download Manager %2. AssignedConfigurationName is %3.
0xb00010ee1011Job %1 : Attempting to get the modules from pull server using Download Manager %2. Agent Id is %3. Modules are %4.
0xb00010ef1011Job %1 : Checksum Validation failed. Client computed checksum is %2 and Checksum Sent from the server is %3.
0xb00010f01011Job %1 : Server has returned a response of UpdateMetaConfiguration. Please update the meta configuration on this node.
0xb00010f11011Job %1 : A ServerUrl was not located in the metaconfiguration for AgentId %2.
0xb00010f21011Job %1 : The current pull request-id is %2.
0xb00010f31011Job %1 : The server response was Header: %2 and Content:%3.
0xb00010f41011The DscTimer is going to start the timer to create task for sending pending report for the first time with value %1 minutes.
0xb00010f51011The DScTimer is updating the timer to create task to send pending report to the value %1 minutes.
0xb00010f61011The DscTimer successfully created the timer to create task for sending pending report.
0xb00010f71011The DscTimer has successfully run LCM method PerformRequiredConfigurationChecks with flag %1.
0xb00010f81011The DscTimer is already performing operation with flag %1,ignoring new request.
0xb00010f91011The DSCStatusHistory.mof is not found at %1.
0xb00010fa1011The DSCConfigurationStatus mof file not found at %1.
0xb00010fb1011Deserializing mof %1 failed.
0xb00010fc1011Failed to process non-terminating error from resource '%1'.
0xb00010fd1011Job %1 : The local configuration manager is attempting to remove the configuration state cache.
0xb00010fe1011Job %1 : The local configuration manager did not find any configuration state cache file to remove.
0xb00010ff1011Job %1 : The local configuration manager failed to remove the configuration state cache file.
0xb00011001011Job %1 : The local configuration manager was able to successfully remove the configuration state cache file.
0xb00011011011Job %1 : LCM has released the resource state cache.
0xb00011311011Job %1 : Attempting to register the Dsc agent with AgentId %2 with the server %3 using Download Manager %4.
0xb00011321011Job %1 : Successfully registered the Dsc agent with AgentId %2 with the server %3 using Download Manager %4.
0xb00011331011Job %1 : Registering Dsc Agent with Agent Id %2. Register-DscAgent command, PUT Url: %3.
0xb00011341011Job %1 : Http Client %2 failed to register Dsc Agent: %3.
0xb00011351011Job %1 : Register-DscAgent command for AgentId %2 succeeded.
0xb00011361011Job %1 : Register-DscAgent command for AgentId %2 using certificate id: %3.
0xb00011371011Job %1 : The Dsc Agent will generate a new AgentId.
0xb00011381011Job %1 : Unable to write AgentId %2 to registry.
0xb00011391011Job %1 : The Dsc Agent with AgentId %2 has already been registered for the Server URL %3. Registration will be skipped for this Server URL.
0xb000113a1011Job %1 : Using Version 1 protocol of Dsc PULL.
0xb000113b1011Job %1 : Attempt to register the Dsc Agent AgentId %2 with Server URL %3 since RegistrationKey was specified.
0xb000113c1011Job %1 : The Dsc Agent with AgentId %2 failed to create a self-signed certificate.
0xb000113d1011Job %1 : The AgentId %2 was written to the registry.
0xb00011951011Telemetry assembly %1 does not successfully load. Load exception message is: %2
0xb00011961011Cannot get type %1 from loaded Dsc Telemetry assembly.
0xb00011971011An error occured when initializing event source instance for Dsc Telemetry assembly. The exception is: %1
0xb00011981011Job %1 : WebDownloadManager for configuration associated with AgentId %2 Get-DscDocument command, File save result: %3.
0xb00011991011Job %1 : WebDownloadManager for configuration associated with AgentId %2 Get-DscDocument command, Checksum validation failed: %3.
0xb000119a1011Job %1 : WebDownloadManager for configuration associated with AgentId %2 Get-DscDocument command, GET Url: %3.
0xb000119b1011Job %1 : WebDownloadManager for configuration associated with AgentId %2 Get-DscDocument command, GET call result: %3.
0xb000119c1011Job %1 : Attempting to send the status report using Report Manager %2. AgentId is %3.
0xb000119d1011Job %1 : Updating PSModulePath with the current value from the registry failed.
0xb000119e1011Job %1 : %2 error writing to job details log %3.
0xb000119f1011Job %1 : %2 error closing job details log %3.
0xb00011a01011Job %1 : Details logging started to %2.
0xb00011a11011Job %1 : Details logging completed for %2.
0xb00011a21011Validating the signer signature chain failed with the status '%1'. A certificate chain could not be built to a trusted root authority.
0xb00011a31011Failed to open trusted publisher store with the error '%1'. The store path is either invalid or does not exist.
0xb00011a41011Failed to retrieve signing certificate information from the trusted publisher store with the error '%1'.
0xb00011a51011Failed to parse trusted publisher store path with the error '%1'.
0xb00011a61011Trusted publisher store path is : '%1'.
0xb00011a71011Signature validation was successful. Signer certificate is valid and trusted.
0xb00011a81011Validating the signer signature trust failed. The signer certificate did not match with any valid code signing certificate that is installed on the node.
0xb00011a91011Validating the signer signature hash failed with the status '%1'. The content of the configuration document or module has been changed.
0xb00011aa1011Validating the signer signature failed with the status '%1'.
0xb00011ab1011Validating the signature of the configuration document failed. The signature status on the document is '%1'.
0xb00011ac1011Signature validation skipped becouse machine signature verification policy is set to '%1'
0xb00011ad1011Extracting the downloaded zip file '%1' failed.
0xb00011ae1011The downloaded zip file '%1' does not contain a catalog file. Ensure the catalog file for the module exist inside the module folder.
0xb00011af1011Catalog signature verification failed for the downloaded zip file '%1'.
0xb00011b01011Comparing the module catalalog with current contents of the module succeeded for module '%1'.
0xb00011b11011Comparing the module catalalog file with current contents of the module failed for the downloaded zip file '%1'. Verify using 'Test-FileCatalog' cmdlet that contents of the module on the server has not changed after it is signed.
0xb00011b21011The Local Configuration Manager could not find the partial configuration block that matches the server assigned configuration document '%1'.
0xb00011b31011The uncompressed file size of the downloaded zip file %1, exceeded the 'MaximumDownloadSizeMB' value of %2 MB provided in the metaconfiguration. Please increase this value in the metaconfiguration if you are expecting module size greater than the current limit.
0xb00011f91011Job %1 : Http Client %2 failed to rotate Dsc Agent registration: %3.
0xb00011fa1011Job %1 : Rotating Dsc Agent registration with Agent Id %2. Rotate-DscAgent command, PUT Url: %3.
0xb00011fb1011Job %1 : Http Client %2 received an unknown rotate header with the value: %3.
0xb00011fc1011Job %1 : Rotate-DscAgent command for AgentId %2 succeeded.
0xb00011fd1011Job %1 : Rotate-DscAgent command for AgentId %2 to certificate id: %3.
260 entries