p2p.dll

Peer-to-Peer Grouping API

Associated Error Codes

Below lists error codes and symbolic names found for this module.

CodeFound inDescription
0x2ced78.110A cloud requested is not present; review the configured IPv6 addresses and verify there are addresses of appropriate scope.
0x2cee78.110Requested cloud has been disabled by your administrator.
0x2cef78.110Identity used for registering a name in the cloud is invalid.
0x2cf078.110Resolve failed because the system is currently overloaded.
0x2cf178.110Registering a name in a cloud that has been configured to be resolve only.
0x2cf278.110Using PNRP in a compartment outside of the default one. PNRP only works in the default compartment.
0x2cf478.110Registering a peername more than one time in the same cloud.
0x63000178.110Graph Properties created for the graph that was opened. It is important to note that certain operations will be limited until this local node has synchronized with other nodes in the graph.
0x63000278.110The event data is not present.
0x63000578.110The sign-in succeeded, but there are no IPv6 addresses available at this time.
0x63000678.110The local peer attempted to join a group based on a password more than once.
0x63200078.110The local peer is already connected to the group or graph
0x63600078.110The specified endpoint has already been subscribed to
0x8063000178.110IPv6 is not installed on this machine. IPv6 is required for the Windows Peer-to-Peer infrastructure.
0x8063000278.110The Windows Peer-to-Peer infrastructure is not initialized. Calling the relevant initialization function is required.
0x8063000378.110One or more of the dependent modules could not initialize. The modules pnrpsvc, p2psvc, p2pimsvc and p2phost must be started. If not started, these modules can be manually started.
0x8063000478.110The Windows Peer-to-Peer infrastructure is not licensed to operate on this platform.
0x8063001078.110An invalid handle to the graph is being used. Use the handle returned after creating or opening the graph.
0x8063001178.110A graph has been opened in the same process with a different database name than it was opened with initially.
0x8063001278.110An attempt has been made to create a graph with a graph ID previously used in the same process. Creation will require a new graph ID.
0x8063001378.110The peer has attempted to perform an operation that requires that requires connectivity, but is not connected to the graph.
0x8063001478.110A graph shutdown is in progress. Graph-related operations cannot be performed.
0x8063001578.110An attempt to import the graph database has been made while the graph is still connected or listening. The graph must be closed prior to this operation.
0x8063001678.110The graph ID in the database being imported is different from the Graph ID found in the path to the database.
0x8063001778.110More attributes than the maximum allowed have been added to a record.
0x8063010378.110An attempt to disconnect a direct connection that does not exist has been made.
0x8063010678.110An attempt to establish a direct connection to yourself has been made.
0x8063010778.110The local peer is already listening on the network.
0x8063010878.110An attempt has been made to perform a graph node-related operation for a node that does not exist.
0x8063010978.110A connection to the graph or group has failed, or a direct connection in a graph or group has failed.
0x8063010a78.110An error has occurred while establishing a connection in a graph or group, or while connecting based on an IP address in a group.
0x8063010b78.110The neighbor in the graph or group are not accepting connections.
0x8063020178.110The classifier is longer than the maximum allowed.
0x8063020278.110The system cannot create additional identities.
0x8063020378.110No access is given to the directory where keys are stored.
0x8063020478.110An attempt to delete an identity which has one or more associated groups has been made. The groups must be deleted prior to the removal of the associated identity.
0x8063030178.110The local peer is using a record that does not exist.
0x8063030278.110The database engine cannot open the database file. The file may be in use by another process or the caller may not have sufficient privileges to open the file.
0x8063030378.110Upgrading the application to run on Vista failed as a result of the database used on the previous OS being unable to load.
0x8063030578.110An attempt has been made to create a graph with the same graph ID, peer ID, and database name as a graph created previously.
0x8063040178.110The local peer is using an identity that does not exist.
0x8063050178.110Using an event handle that does not exist.
0x8063060178.110The format specified for a search string is not valid.
0x8063060278.110The format specified for attributes is not correct when adding a record.
0x8063070178.110The invitation used to join the group is not valid.
0x8063070378.110An attempt has been made to create an invitation or issue credentials that are longer than the maximum allowance. Credentials retrieved from the group creator are preferred.
0x8063070578.110This is returned when the time values supplied during the creation of invitations or credentials are incorrect.
0x8063070678.110The invitation has an illegal circular chain. For example, A invites B, and then B invites A.
0x8063080178.110The Identity Store has been corrupted. Delete idstore.sst from the %appdata%\peernetworking folder.
0x8063100178.110An attempt has been made to access a cloud that does not exist.
0x8063100578.110There is more than one cloud with the same scope. The cloud must be accessed specifically.
0x8063201078.110The record is invalid.
0x8063202078.110An attempt has been made to perform an unauthorized operation.
0x8063202178.110Password specified does not meet domain policy requirements.
0x8063203078.110The graph security layer cannot verify the record at this time.
0x8063204078.110The group properties specified are invalid.
0x8063205078.110The format of the peer name specified is invalid.
0x8063206078.110The classifier specified is invalid.
0x8063207078.110The friendly name specified is invalid.
0x8063207178.110The role specified is invalid.
0x8063207278.110The classifier in the invitation used while joining the group is invalid.
0x8063208078.110The record expiration specified is invalid.
0x8063208178.110The credential information specified is invalid.
0x8063208278.110An invitation specified for joining the group is invalid.
0x8063208378.110The record size specified is invalid.
0x8063209078.110This version is not supported.
0x8063209178.110This error is returned when not connected to the group while trying to perform an operation that requires connectivity.
0x8063209278.110An attempt has been made to import the group database while the group is still connected . The group must be closed prior to this operation. The error is also returned while trying to join a group that is already open.
0x8063209378.110The group handle is invalid or the group has been marked for deletion.
0x8063209478.110A connection to a group has failed because there are no active members in the group.
0x8063209578.110A connection to a group has failed because the member found could not accept the connection.
0x8063209678.110The local peer is unable to listen. The port requested may not be available.
0x806320a078.110An identity being used in the operation has been deleted.
0x806320a178.110The Peer-to-Peer Collaboration infrastructure is not available.
0x8063400178.110The conversion from a peer name failed. It has an invalid format or is too long.
0x8063400278.110The conversion from a host name to a peer name has failed. It is possible the format of the host name is incorrect.
0x8063400378.110No endpoints left.
0x8063400578.110A peer name has been registered more than once in the same cloud.
0x8063600178.110The contact requested was not found.
0x8063700078.110An application invite has been cancelled.
0x8063700178.110A response is not available. Wait for the event to be signaled.
0x8063700378.110The operation requires the user to be signed in.
0x8063700478.110The user has chosen not to start People Near Me by declining the privacy dialog. The privacy will appear the next time the user attempts sign-in.
0x8063700578.110The local peer timed out while trying to connect to the endpoint to subscribe or invite to.
0x8063700778.110The address specified is invalid.
0x8063700878.110The firewall exception, Windows Peer-to-Peer Collaboration Foundation, is disabled. The exception can be enabled by accepting the People Near Me privacy dialog or directly from within the firewall UI.
0x8063700978.110The firewall exception, Windows Peer-to-Peer Collaboration Foundation, is blocked by group policy. Talk to your administrator about enabling this exception.
0x8063700a78.110No exceptions made in firewall policy.
0x8063700b78.110If you click Cancel in the "Set up People Near Me" dialog box, People Near Me cannot sign you in. To reopen the setup dialog box, try signing in again.
89 entries